PDA

View Full Version : Array Dive Error



briner
12-12-2006, 11:21 AM
I ran into this error when I was trying to dive into an array:


Fatal Error: Found a dive_scope for a non-scope display

File: gen_data_binding.cxx
Expression: Sym ->is_a_scope()
Line:3058

The tv gui froze, so I had to kill the process.

PeterT-RogueWave
12-14-2006, 07:25 AM
Well, that certainly looks like a bug.

I you haven't done so already, could you report this and the details (language, compiler versions, platform, type of the array, allocated/static , TotalView version, etc, etc) to support@etnus.com? That's the only way we can officially track this problem and hopefully come to a resolution.

Thanks,
Peter

briner
12-14-2006, 09:10 AM
I'll do that. Here's more info from the user:



Basically, it crashed when I tried to view the array in a different way. Generally, the array is displayed as (:,:) such that

(1,1)
(2,1)

(n,1)
(1,2)
(2,2)

(n,2)


I wanted to view the array as (1,:) so that I can see

(1,1), (1,2), …, (1,n)

This works for other arrays I checked. But for some reason, one of the array is causing a problem and it crashes. The array I am looking at is common block type of array from our include file. I wonder if its causing problem because it’s a common block?

PeterT-RogueWave
12-14-2006, 09:29 AM
It seems a bit unusal that it would just be a common block that is causing the problem, but I won't rule it out. If it's g77, then it's a better than average chance that being common might be the cause of the problem. Not much development is going on in the g77 compiler itself lately, and we haven't been focused there. By all means let us know at the support site.

Pete

Josh-TotalView-Tech
08-10-2007, 07:35 AM
This was a TotalView bug, 9715, which was fixed in TotalView 8.1.0-0.