PDA

View Full Version : Why can't TotalView V8.0.2-0 find its installation directory?



Tom-TotalView-Tech
02-13-2007, 12:53 PM
There is an issue in the tv8 and tv8cli start-up scripts. Symbolic links for TVROOT are not handled correctly in these wrapper scripts.

The fix requires the modification of these scripts:

<InstallBaseDir>/toolworks/totalview.8.0.2-0/bin/tv8
<InstallBaseDir>/toolworks/totalview.8.0.2-0/bin/tv8cli

At line 149 in both files, modify the body of the conditional "if" statement as follows:
From:



if [ -n "$l" ]; then
TVROOT="$l"
fi

to:



if [ -n "$l" ]; then
case "$l" in
/*) TVROOT="$l"
;;
*) TVROOT=`dirname "$TVROOT"`/"$l"
;;
esac
fi

Josh-TotalView-Tech
10-30-2007, 11:37 AM
This problem was fixed in TVD version 8.1.0-0.

staron
10-24-2008, 08:27 AM
[:)]

I have similar problem with student edition ./totalview.8.6.0-3-linux-x86.tar

Please, help me solve it.

Verifying archive integrity... All good.
Uncompresing TotalViewInstaller......
Host PLATFORM = linux-x86
Looking for installer tarfile ./workbench_installer.1.4.0-3-linux-x86.tar
Expanding ./workbench_installer.1.4.0-3-linux-x86.tar ...
... done
checking tarfile: ./totalview.8.6.0-3-linux-x86.tar
Expanding ./totalview.8.6.0-3-linux-x86.tar ...
... done

and totalview individual install Wizard opens

however, I've run into the problem:
After entitlement code has been entered, it is asking to enter the derictory
containing your TotalView Debugger Individual installation:

I tried everything ...




There is an issue in the tv8 and tv8cli start-up scripts. Symbolic links for TVROOT are not handled correctly in these wrapper scripts.

The fix requires the modification of these scripts:

<InstallBaseDir>/toolworks/totalview.8.0.2-0/bin/tv8
<InstallBaseDir>/toolworks/totalview.8.0.2-0/bin/tv8cli

At line 149 in both files, modify the body of the conditional "if" statement as follows:
From:



if [ -n "$l" ]; then
TVROOT="$l"
fi

to:



if [ -n "$l" ]; then
case "$l" in
/*) TVROOT="$l"
;;
*) TVROOT=`dirname "$TVROOT"`/"$l"
;;
esac
fi