View Full Version : not able to run memescape script

05-23-2007, 02:05 AM
I am working on sun FIRE T200 machine with solaris10 installed on it.
I am not able to run memscape script. I used terminal emulator and no output on that.
I dont think machine is hanging because cursor is still blinking.

Here are steps I followed during installation. I am using sun fire T200 server with Solaris10 Installed on it. I downloaded memoryscape.2.0.0-0-sun5.tar and memoryscape.2.0.0-0-doc.tar to my local folder. I don’t have root password so I extracted both files to memorycape folder in home directory. Then in memoryscape.2.0.0-0 folder I give command :./Install And Installed all component. I copied my license.demo file to flexlm-10.8.0-3 directory.
I tried changing LM_LICENSE_FILE variable to point to license.demo file and also set PATH variable but still same problem persists.

07-11-2007, 11:49 AM
It looks like this one is a bit old and was never answered. Sorry, but this is a question that would have benefited by sending the question to support@totalviewtech.com. We're not always looking in here as time doesn't always give us the time to do so.

That said, is this still a problem? Can you tell me what the output of memscape is when you try to run it at the console?


07-11-2007, 11:24 PM
Thanks for replying.
I reported this problem to totalviewsupport team. I provided them screenshot my xwindow. They ask me to run strace command but I dont have read permission to /dev/log file and thats where we are stuck.

Actually when I run memsacpe through console I dont get any output thats the problem. I reinstalled it 3 times but still same problem. I dont think machine gets hanged because cursor still blinks.

09-17-2007, 11:59 AM
After looking into this issue for some time in technical support we were unable to reproduce or locate the cause of the problem. However, we were able to find a workaround to the issue. The workaround is to invoke the memoryscape binary directly by executing:

<install_root>/toolworks/memoryscape.<version>/../totalview.<relative_tvd_version>/<arch>/bin/memscapemain -root <install_root>/toolworks/totalview.<relative_tvd_version>

Where <install_root> is the directory you installed in. <version> is the MemoryScape version you installed, <relative_tvd_version> is the version of the TotalView Debugger that was installed when you installed MemoryScape <version>, and <arch> is the architecture that you are attempting to run MemoryScape on.

12-29-2007, 08:23 AM
I have the same problem with memscape.
I can' t run it even I had a license demo.
What can I do please?

01-02-2008, 03:48 PM
There are TotalView demo licenses and MemoryScape demo licenses and they are separate. If you do have a memoryscape demo license, and still can't run it, let us know.