PDA

View Full Version : TotalView student edition - installation issues on Ubuntu 12.04



ErikArthur
09-15-2014, 05:23 PM
Hi there,

So I have my account to ftp the bits and the entitlement code. I have downloaded the totalview_individual.8.14.0-21-line-x86-64.sh and was able to install it but the entitlement code didn't work. The error was something about not being able to connect to the licensing server. So I took a unrationale approach and deleted the installed bits and tried to reinstall. Now when I run the sh command - "sudo ./totalview_individual.8.14.0-21-line-x86-64.sh" it logs me out of Ubuntu - literally logs me out of the system. This happens on a couple of different virtual mmachines. What am I doing wrong and how to I eventually license this beast?

Thanks,

Erik Arthur
arth0002@umn.edu

ErikArthur
10-05-2014, 08:14 AM
I figured it out the license issue. The Linux Standard Base (LSB) components needed to be installed and aren't installed by default on a debian system.

Install them with apt-get install lsb and rerun setup.

I still don't know why the installation script wouldn't generate UI occassionally. I ended up adding a ubuntu 14.04 vm to my machine and installation ran fine in that vm. Once I figured out that lsb was missing then it all fell into place.

Hope this helps someone else as RogueWave didn't reply to this forum post or my email after a while. Still totalview looks like a nice tool and hopefully I won't need any additional help.

E

PeterT-RogueWave
10-09-2014, 08:43 AM
Hi Erik,

Sorry about not replying here. We don't montior this board as much as we should. The problem with LSB 3 compliance is known and is mentioned in our release notes for 8.14.1. Since you are running on Ubuntu, you should also be aware of the ptrace_scope issue. If /proc/sys/kernel/yama/ptrace_scope is set to '1' (the default) you will not be able to attach to a running process or debug with MPI. You may have already found that note in the forum, since I'm sure I've written about it before. This is also doucmented in the release notes with a full explanation of what to do about it.

As for not replying to the email, note that the only valid email these days is 'support@roguewave.com'. Any send to the older TotalView email addresses are just likely to get lost in cyberspace. Someone should always reply, even if it is just to ask for your license number, so I'm not sure what may have happened here.

Regards,