PDA

View Full Version : JViews cannot run under Java 7 update 101 or Java 8 update 101



charego
07-28-2016, 09:36 AM
ILOG JViews version: 8.1p8

It fails with the following exception under both JREs:



Caused by: java.lang.IllegalArgumentException: Minor revision must be 0 <= 101 < 100
at ilog.views.util.swing.IlvSwingUtil$Version.<init>(Unknown Source)
at ilog.views.util.swing.IlvSwingUtil.a(Unknown Source)
at ilog.views.util.swing.IlvSwingUtil.getSwingVersion (Unknown Source)
at ilog.views.util.swing.IlvSwingUtil.<clinit>(Unknown Source)
... 31 more


Why must the revision number be less than 100?

Do later versions of JViews support running under updates greater than or equal to 100?

charego
08-01-2016, 06:50 AM
According to a support email:


There is a known problem, JV-7857, with JViews versions 8.8 and prior.

The problem is related to Java patch versions >=100.

We have fixed this problem in our latest version of JViews 8.9.

donb
08-01-2016, 09:24 AM
The most recent releases for Java 7 and Java 8 have update levels greater than 99, causing an issue with Visualization for Java (JViews). More information on Java releases are found on the Oracle webpage (https://www.java.com/en/download/faq/release_dates.xml?mkt_tok=eyJpIjoiWVRnNFlqSTVNVGcz TlRRNCIsInQiOiJncGFKWmhWbzlHNFBBVlAzbkxJT1gyUUx6NG ZpaUsySjFYUkw2UzQ5Q2RQclgyb3BEUXBKTGc0Uk05SmVNYnZM QUtxSmg4WDZHYjhvb2VYMkRYc1hjQT09In0%3D).

Our support team is managing this issue and releasing patches to our customers. If you have a current maintenance and support agreement, please contact support (support@roguewave.com) for a patch. All other customers should contact their Rogue Wave account manager (sales@roguewave.com) to obtain support.

If you have any other questions, please email us at info@roguewave.com.

Thomas Schulte
09-27-2016, 11:53 PM
Mine is even nicer. I got the same problem but with a really old version of Jviews 8.0

I know where the problem is and i just would need the two excutable jar files where this part of the code sits jviews-graphics-framework-lib.jar and jviews-util-lib.jar.

And there is no way for me to update to the lastest version.

donb
10-03-2016, 09:35 AM
Hello Thomas,

We are able to address "a really old version". As stated in the previous post - contact support or your account executive based upon you having or not having a current support agreement respectively.

Cheers, Don B.