PDA

View Full Version : Want to know the exact Source Pro version compatible with Red Hat Linux 7.3



Bidyut Mandal
03-06-2017, 05:16 AM
What Source Pro version is certified and officially tested with RedHat Enterprise Linux 7.3?
RHEL 7.3 is our existing Operating system. We have to port our product into RHEL 7.3(client recommended) which is developed using SourcePro libraries.
So we need to know the exact Source pro version which is compatible with RHEL 7.3.

dean
03-07-2017, 02:17 PM
The current version of SourcePro (2016.1) supports the Redhat Enterprise Linux 7.3. Here is a link to the current supported platforms document for SourcePro:

http://docs.roguewave.com/sourcepro/2016.1/SourcePro_2016.1_Supported_Platforms.pdf

Bidyut Mandal
03-08-2017, 03:12 AM
In SourcePro(2016.1) supported matrix, Only Redhat Enterprise Linux 7 is mentioned but no update is there. So my question is whether it is compatible with Redhat Enterprise Linux 7.3 or not.

My next question is, in SourcePro(13.1) same Redhat version ( Redhat Enterprise Linux 7) is mentioned. Is SourcePro(13.1) compatible with Redhat Enterprise Linux 7.3 ?

dean
03-08-2017, 09:37 AM
SourcePro 2016.1 was the first release to remove the maintenance level of the OS on Redhat. So the current release of SourcePro 2016.1 supports Redhat 7.x with gcc 4.8.x compiler. Any previous version of SourcePro would include the maintenance level of the OS, so SourcePro 13.1 would only officially support Redhat 7.0 release.

Bidyut Mandal
06-20-2017, 01:23 AM
Is SourcePro 2016.2 also removed the maintenance level of the OS? Actually we want to use it in Solaris10 with Oracle 12.1.0.2. So what will be the exact OS version and compiler version for the same. Is SourcePro 2016.2 dependent on Oracle maintenance version also?

dean
06-23-2017, 10:18 AM
According to the support matrix for SourcePro 2016.2: http://docs.roguewave.com/sourcepro/2016.2/SourcePro_2016.2_Supported_Platforms.pdf
The platform is Solaris 10 with 2 different compiler, Oracle Solaris Studio 12.4 and Oracle Developer Studio 12.5. The Oracle client tested with is Oracle 12C (12.1.0.2). If you have further questions I would recommend contacting Rogue Wave Support.