PDA

View Full Version : Problems with SURFACE_FIT in PV-Wave 9.0



Wedge Antilles
07-11-2008, 05:15 AM
Hi,

I'm having problems with the SURFACE_FIT function in PV-WAVE 9.0 (Windows 32-Bit). For example, in the denoted example program

OPENR, 1, !Data_dir + 'pikeselev.dat'
data = FLTARR(60, 40)
; Read in the data from the pikes elevation file.
READF, 1, data
; Close the input file.
CLOSE, 1
; Show the raw data without fitting.
SURFACE, data
; Approximate a linear least-squares fit.
SURFACE, SURFACE_FIT(data, 1)
; Do a second-degree polynomial fit.
SURFACE, SURFACE_FIT(data, 2)
; Do a third-degree polynomial fit.
SURFACE, SURFACE_FIT(data, 3)
; Do a forth-degree polynomial fit.
SURFACE, SURFACE_FIT(data, 4)
; Do a fifth-degree polynomial fit.
SURFACE, SURFACE_FIT(data, 5)

the third- and higher-degree polynomial fits don't work correctly. Retrying "SURFACE, SURFACE_FIT(data, 3)" (as an example) leads to different (wrong) results.
Sometimes I get this error message:

% Array has a corrupted descriptor: KK.
% Execution halted at POLYWARP <polywarp.pro( 87)> .
% Called from SURFACE_FIT <surface_fit.pro( 63)>.
% Called from $MAIN$ .

This problem doesn't occur with version 8.5. Furthermore, it seems to affect only multi-core systems.
Any suggestions? :confused:

Thanks,
Markus

donb
07-11-2008, 08:27 AM
Hi Markus,

Our suggestion is to download and install PV-WAVE v9.01. My machine is a multi-core and I don't see the issues you report using 9.01.

You can download the latest version from the VNI website here (http://www.vni.com/products/wave/pvwave/download.php).

Don B.

rwagner
07-11-2008, 09:12 AM
I can't reproduce this either on my (multicore) machines running 9.01
-Ryan

rwagner
07-11-2008, 11:24 AM
Upon further examination, I did not get the same error messages as you did, but I did get errors.

In the GUI on Windows 9.0: SURFACE, SURFACE_FIT(data, 3) gave me a warning about the range being reset and did not plot.

In the console on Windows 9.0 SURFACE, SURFACE_FIT(data, 4) crashed.

All of these work fine with PV-WAVE 9.01

Wedge Antilles
07-14-2008, 03:45 AM
Thanks a lot!

With v9.01, "SURFACE_FIT" works without any problems on my machine, too. :)