MemoryScape doesn't create guard blocks unless you tell it to. Enable them by selecting <b>Medium</b> on the <b>Memory Debugging Options</b> screen.