Results 1 to 6 of 6

Thread: LEIF 1.2 VS2010 support

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Posts
    1

    LEIF 1.2 VS2010 support

    Hi, we are using LEIF (XMLObjectLink) 1.2 version for generating C++ classes compatible with VC6 projects. In LEIF 1.2 documentation it is mentioned that it is generating C++ classes platform independent? It can happen when it generates ISO C++ classes.
    We are migrating to VS2010 so do we require to upgrade LEIF libraries?
    I came to know that LEIF is merged with HydraExpress. Can you please provide information which version of LEIF/HydraExpress is compatible with VC10 or it's no support.
    Last edited by Madhur; 11-17-2011 at 02:42 AM. Reason: Incomplete Question

  2. #2
    Administrator
    Join Date
    Mar 2008
    Posts
    12
    You are correct LEIF became HydraExpress. The latest version of HydraExpress is 4.6 and it does support VS 2010.
    Linda
    Rogue Wave
    Technical Support

  3. #3
    Administrator
    Join Date
    Mar 2008
    Posts
    12
    The use cases for HydraExpress and LEIF 1.2 are largely the same. HydraExpress 4.6 supports current platforms where LEIF 1.2 was developed about 7 or 8 years ago and supports platforms that were current at that time. There have been numerous bug fixes and the API has been improved.
    Linda
    Rogue Wave
    Technical Support

  4. #4
    Administrator
    Join Date
    Mar 2008
    Posts
    12
    You will need to upgrade to HydraExpress 4.6 for support of VS2010.

    LEIF and HydraExpress are platform independent in the sense that you can generate code independently on multiple supported platforms and the behavior will be the same on those platforms. That does not mean that you can generate code on one platform and expect it to run on another platform as the binaries will be different.
    Linda
    Rogue Wave
    Technical Support

  5. #5
    Administrator
    Join Date
    Mar 2008
    Posts
    12
    You are welcome! Thanks for posting.
    Linda
    Rogue Wave
    Technical Support

  6. #6
    Administrator
    Join Date
    Mar 2008
    Posts
    12

    The current version of HydraExpress is 4.8.

    HydraExpress is currently at version 4.8. You'll find the supported platforms at www.roguewave.com/help-support/documentation/hydraexpress#4-8-0.
    Linda
    Rogue Wave
    Technical Support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •