Results 1 to 5 of 5

Thread: JViews cannot run under Java 7 update 101 or Java 8 update 101

  1. #1
    Junior Member
    Join Date
    Jul 2016
    Posts
    2

    JViews cannot run under Java 7 update 101 or Java 8 update 101

    ILOG JViews version: 8.1p8

    It fails with the following exception under both JREs:

    Code:
    Caused by: java.lang.IllegalArgumentException: Minor revision must be 0 <= 101 < 100
      at ilog.views.util.swing.IlvSwingUtil$Version.<init>(Unknown Source)
      at ilog.views.util.swing.IlvSwingUtil.a(Unknown Source)
      at ilog.views.util.swing.IlvSwingUtil.getSwingVersion(Unknown Source)
      at ilog.views.util.swing.IlvSwingUtil.<clinit>(Unknown Source)
      ... 31 more
    Why must the revision number be less than 100?

    Do later versions of JViews support running under updates greater than or equal to 100?

  2. #2
    Junior Member
    Join Date
    Jul 2016
    Posts
    2
    According to a support email:

    There is a known problem, JV-7857, with JViews versions 8.8 and prior.

    The problem is related to Java patch versions >=100.

    We have fixed this problem in our latest version of JViews 8.9.

  3. #3
    Grand Poobah donb's Avatar
    Join Date
    Aug 2005
    Location
    Colorado
    Posts
    147
    The most recent releases for Java 7 and Java 8 have update levels greater than 99, causing an issue with Visualization for Java (JViews). More information on Java releases are found on the Oracle webpage.

    Our support team is managing this issue and releasing patches to our customers. If you have a current maintenance and support agreement, please contact support for a patch. All other customers should contact their Rogue Wave account manager to obtain support.

    If you have any other questions, please email us at info@roguewave.com.
    Don Boughey
    PV-WAVE Advocate

  4. #4
    Junior Member
    Join Date
    Sep 2016
    Location
    munich
    Posts
    1
    Mine is even nicer. I got the same problem but with a really old version of Jviews 8.0

    I know where the problem is and i just would need the two excutable jar files where this part of the code sits jviews-graphics-framework-lib.jar and jviews-util-lib.jar.

    And there is no way for me to update to the lastest version.

  5. #5
    Grand Poobah donb's Avatar
    Join Date
    Aug 2005
    Location
    Colorado
    Posts
    147
    Hello Thomas,

    We are able to address "a really old version". As stated in the previous post - contact support or your account executive based upon you having or not having a current support agreement respectively.

    Cheers, Don B.
    Don Boughey
    PV-WAVE Advocate

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •