Results 1 to 3 of 3

Thread: mkl_lapack_ao_zgeqrf could not be located

  1. #1
    Junior Member
    Join Date
    Mar 2018

    mkl_lapack_ao_zgeqrf could not be located

    I'm (still) trying to validate, and after successfully compiling imslmp.f90, I get the following error when I try to run imslmp.exe as per the installation instructions:

    The procedure entry point mkl_lapack_ao_zgeqrf could not be located in the dynamic link library mkl_intel_thread.dll.
    I'm running a Windows 7 machine with Visual Studio Community 2015, Intel Parallel Studio XE 2018, and the IMSL FNL 2018.0.0. I'm compiling (%F90% %F90FLAGS% imslmp.f90 $LINK_FNL%) and executing on via command line (Intel 64 Visual Studio 2015 environment).

    (I've also tried appending the following to %path%, where mkl_intel_thread.dll appears to be: ;%IFORT_COMPILER18%redist\ia32\mkl;%IFORT_COMPILER 18%redist\intel64\mkl)

    Any help appreciated. Thank you!

  2. #2
    Join Date
    Feb 2008
    Based on the error, I would say the issue is that some changes in the Intel Parallel Studio XE 2018 has caused some problems. According to the support matrix for IMSL Fortran Library 2018.0 they have certified only the Intel 2017 u2 compiler. If you search on that missing entry point symbol, it makes reference that the Intel MKL 2018 update, which ships with the Parallel Studio XE 2018, breaks its backward compatibility with binaries that are linked with an older version of Intel MKL.

    My suggestion is to use the supported Intel compiler version and see if that works for you.

    Jeremy Dean
    Rogue Wave Software
    Technical Support

  3. #3
    Junior Member
    Join Date
    Mar 2018
    Yes, I went back and installed Intel Parallel Studio 2017u2, and it worked.

    (although I now have a stack overflow problem, but this seems like a more common, well-defined, and Google-able problem from what I can tell.)

    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts