Results 1 to 5 of 5

Thread: Error message in executing

  1. #1
    Junior Member
    Join Date
    Jan 2019
    Posts
    3

    Error message in executing

    I was using IMSL library with student license. But when I execute the Fortran code in debug mode under Microsoft Visual Studio, I got the following error message:

    The procedure entry point for_realloc_lhs could not be located in the dynamic link library C:\Program Files(x86)\RogueWave\imsl\fnl-2018.0.0\win700in170x64\lib\imslmkl_dll.dll

    It worked some time ago. I have no clue what could be the problem. Can someone help me out?

  2. #2
    Senior Member mecej4's Avatar
    Join Date
    Dec 2009
    Posts
    127
    Please state which version of the Intel Fortran compiler was used, the compiler options used, and the PATH in effect when running the program in VS x64/debug.

    I suspect that you used a more recent version of Ifort than the 17.0 version that was used to compile the IMSL libraries. If this is so, ensure that the directory containing the MKL DLLs that came with the compiler occur earlier in PATH than the directory containing the MKL DLLs that came with IMSL.

    Depending on what your source code is intended to do, you may consider using the /assume:norealloc_lhs or the new /nostandard-realloc-lhs options of the 17.0 and later Ifort compilers.
    Last edited by mecej4; 01-11-2019 at 04:32 AM.

  3. #3
    Junior Member
    Join Date
    Jan 2019
    Posts
    3
    Thanks for the reply.

    Here is the information:
    1. My Fortran compiler is version 16.0.4.
    2. The compiler options are:
    /nologo /debug:full /Od /heap-arrays0 /I"..\include" /recursive /warn:noalignments /real_size:64 /module:"x64\Debug" /object:"x64\Debug" /Fd"x64\Debug\vc100.pdb" /traceback /check:bounds /check:stack /libs:dll /threads /dbglibs /Qmklarallel /c
    3. The compiler PATH for libraries are:
    $(IFortInstallDir)compiler\lib\Intel64_win
    $(IFortInstallDir)mkl\lib\Intel64_win
    $(VCInstallDir)atlmfc\lib\amd64
    $(VCInstallDir)lib\amd64
    $(WindowsSdkDir)lib\x64
    C:\Program Files (x86)\RogueWave\imsl\fnl-2018.0.0\win700in170x64\lib

    For Includes the PATH are:
    $(IFortInstallDir)compiler\include
    $(IFortInstallDir)compiler\include\Intel64
    $(IFortInstallDir)mkl\include
    $(VCInstallDir)atlmfc\include
    $(VCInstallDir)include
    $(WindowsSdkDir)include
    $(FrameworkSDKDir)include
    $(WindowsSdkDir)include\um
    $(WindowsSdkDir)include\shared
    C:\Program Files (x86)\RogueWave\imsl\fnl-2018.0.0\win700in170x64\include\static

    I tried the option of /assume:norealloc_lhs and ended up with the same error message. The compiler was only updated once to include MKL.

  4. #4
    Senior Member mecej4's Avatar
    Join Date
    Dec 2009
    Posts
    127
    The additional information that you provided shows that the mismatch is not as I guessed it to be, but that the compiler you are using is older than the one that IMSL 2018 is compatible with. As you can see from https://docs.roguewave.com/imsl/fort...platforms.html , the compiler has to be 17.0 or newer. The 16.0 Fortran runtime did not contain the entry point for_realloc_lhs().

    If you are entitled to update your compiler to 17.0 or newer, that would be the best solution. If not, there is a hack worth trying, with the risk of spending some time with no guarantee of success: you can download and install the Intel Parallel Studio redistributables package 2017 from https://software.intel.com/en-us/art...ies-by-version . When running your EXE, you would have to set PATH so that the 17.0 RTL is used rather than the 16.0 RTL.

  5. #5
    Junior Member
    Join Date
    Jan 2019
    Posts
    3
    I'll try to update the compiler to the new version to see if it works. Thanks a bunch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •