Results 1 to 2 of 2

Thread: New Error loading IMSL C Numerical Library

  1. #1

    New Error loading IMSL C Numerical Library

    Hi forum members,

    I recently found an error when I tried to load the IMSL C Numerical Library. It was working before (until three days ago) and I guess some software update is preventing the PyIMSL from running now. I decided to re-install the wrappers (I am running Ubuntu 10.04 64 bits and I follow the procedure of the forum for nonstandard PyIMSL 1.5 installation option 2) but it didn't solve the problem.

    The same error pops up each time:
    Please set your LD_LIBRARY_PATH to include the directory containing IMSL C Numerical libraries.

    I have checked the LD_LIBRARY_PATH and It is ok. I then I thought there might be a dependency error and checked the dependencies of and and I found some issues in the outputs:

    mauricio@mauricio-laptop:/opt/pyimsl/imsl/lib$ ldd => (0x00007fff7717d000)
    /export/er/CNL7/build/rdhgc411e64/lib/ => not found
    /export/er/CNL7/build/rdhgc411e64/lib/ => not found => /lib/ (0x00007f05ac0fe000)
    /lib64/ (0x00007f05ac6b6000)

    mauricio@mauricio-laptop:/opt/pyimsl/imsl/lib$ ldd => (0x00007fff3b3ff000) => not found => not found => not found => /opt/pyimsl/imsl/mkl/ (0x00007fe4c5535000) => /opt/pyimsl/imsl/mkl/ (0x00007fe4c51d1000) => /opt/pyimsl/imsl/mkl/ (0x00007fe4c4ffe000) => /opt/pyimsl/imsl/mkl/ (0x00007fe4c48bf000) => /opt/pyimsl/imsl/mkl/ (0x00007fe4c4754000) => /usr/lib/ (0x00007fe4c4466000) => /lib/ (0x00007fe4c40e3000) => /lib/ (0x00007fe4c3edf000) => /lib/ (0x00007fe4c3cc1000) => /lib/ (0x00007fe4c3a3e000)
    /lib64/ (0x00007fe4c5a77000)

    The libraries that could not be found are in the same location /opt/pyimsl/imsl/lib. Do you think that unresolved dependencies is the reason of my problem? Is there any solution? Before hand thank you.


  2. #2
    Junior Member
    Join Date
    Sep 2005
    You are right that unresolved dependencies in and libimslmathstat_mkl are causing loading errors. Most of the time dependency errors are caused by not having the imsl libraries in the the LD_LIBRARY_PATH. However, if you already have /opt/pyimsl/imsl/lib in your LD_LIBRARY_PATH and still seeing this error then looking at dependencies of individual files might be helpful. Please provide ldd output for the following files:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts